Microchip MPLAB Harmony for PIC32MX (UART CLOCK ISSUE)

Microchip MPLAB Harmony for PIC32MX (UART CLOCK ISSUE)

Postby neptunis2016 » Fri Dec 09, 2016 1:15 am

Hi,

First of all, this is my first post here! I tried to login Microchip Forum, but last two days I still awaiting validation email for I be able to login microchip forum :cry:

I am beginning in Microchip and I am trying to configure and test some communications in PIC32 Microcontrollers. I am using the new platform MPLAB Harmony.

I already tested the static and dynamic UART driver using PIC32MZ and using as help the Wiki Microchip project examples. However, I am trying to test a PIC32MX170 microprocessor with same platform and I am not obtaining the same results. I am checking the HyperTerminal and characters are random in UART communication. It seems the clock is not well configured. But I am not figure where is my mistake.

Anyone can help me?
I can send the basic code source and pictures for a more experience engineer can help me.

Thank you in advance
neptunis2016
 
Posts: 1
Joined: Fri Dec 09, 2016 1:02 am

Re: Microchip MPLAB Harmony for PIC32MX (UART CLOCK ISSUE)

Postby AussieSusan » Thu Mar 09, 2017 3:27 am

Post your code, especially the config settings and the oscillator configuration.
There can be quite a step learning curve getting the basics of programming Microchip devices working correctly so I suggest that you start with a 'flash a LED' program. By the time you get that working you will know how to use the IDE, the programmer, the config settings and the oscillator setup.
After that it all gets easier as you can start to concentrate on the coding itself, rather than getting the MCU to do what you want.
Susan
AussieSusan
Verified identity
 
Posts: 56
Joined: Mon Jun 16, 2014 4:45 am
PIC experience: Experienced Hobbyist


Return to PIC32 topics

Who is online

Users browsing this forum: No registered users and 1 guest

cron