Problem with PIC12F1572 and PICkit3

(instructions, reset, WDT, specifications...) PIC12F6xx, PIC16Fxxx, PIC16F6x, PIC16F7x

Problem with PIC12F1572 and PICkit3

Postby evgeni92 » Thu Sep 17, 2015 12:18 pm

Hi everyone! This is my first topic on this forum.
I have pic12F1572 and I try to connect with pickit3 but I can't. I read the problem is maybe in the version on pickit3. I look the last version is 3.1.0 and I use that version. And pickit3 can't find pic12f1572. I need the help how can I solve the problem. Anyone have that problem. Or anybody use PIC12F1572 with pickit3 and can connect with pickit3. From where can download last update for pickit3, which is working with pic12f1572. I download and MPLAB X 3.10. But again I can't connect with PIC12F1572. In the computer I have and MPLAB IDE 8.92. What I was doing wrong.
Is have someone else programmer when is working with pic12f1572.
Sorry for my bad english.
evgeni92
 
Posts: 6
Joined: Thu Sep 17, 2015 12:03 pm

Re: Problem with PIC12F1572 and PICkit3

Postby ric » Thu Sep 17, 2015 9:31 pm

This is more likely a problem with how you have connected the PK3 to the PIC, or how you are powering the PIC.
Are you able to use the PK3 with any other PIC parts?
How exactly have you connected it to the PIC12F1572?
What are you trying to do, and what messages are you seeing?
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 398
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products

Re: Problem with PIC12F1572 and PICkit3

Postby evgeni92 » Fri Sep 18, 2015 5:57 am

I used Pickit3 with PIC18F6722 and is working correct. When I try connect PIC12F1572 the message is No device detected. And then I try find in "Device Family", and couldn't find. I know what is the problem. The problem is The pickit3 update is old and is not support this pic. The problem is I can't find OS who is have pic12f1572. I try with MPLAB X 3.10, and I can't. I'm not sure correct try with MPLAB X. If is possible to give me link from where can find update for pickit3 who support pic12f1572.
evgeni92
 
Posts: 6
Joined: Thu Sep 17, 2015 12:03 pm

Re: Problem with PIC12F1572 and PICkit3

Postby ric » Fri Sep 18, 2015 6:36 am

MPLAB comes with the PICkit firmware built in. You don't have to download anything else.

And then I try find in "Device Family", and couldn't find.

What progrm/IDE are you running when you can't find it?
It is certainly in MPLABX3.10 if you start a new project. It's in the "Mid-Range 8-bit MCUs" family.
Note the list is sorted alphabetically, so the PIC12F1840 comes just before the PIC12F609, and so on.

The problem is The pickit3 update is old and is not support this pic.

What "pickit3 update" ? MPLABX comes with the latest PK3 firmware.
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 398
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products

Re: Problem with PIC12F1572 and PICkit3

Postby evgeni92 » Fri Sep 18, 2015 7:19 am

I can't find in Device Family from Pickit3 programmer app. And my last update for pickit3 is BUR111096290. I'm not using MPLAB X for create project and write the code for pic. I use CCS C Compiler. And for import hex file on pic microproccesors I use only PICkit3. For pic18f6722 is not the problem this method. But now pickit3 is not detected pic12f1572. I'm new in embedded programming. I download MPLAB X 3.10 just for update pickit3 but is can't update. I'm sorry for my bad english.
Thanks for the help.
evgeni92
 
Posts: 6
Joined: Thu Sep 17, 2015 12:03 pm

Re: Problem with PIC12F1572 and PICkit3

Postby ric » Fri Sep 18, 2015 7:33 am

Use the "MPLAB IPE" tool that comes with MPLABX 3.10, instead of the old standalone PK3 app.
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 398
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products

Re: Problem with PIC12F1572 and PICkit3

Postby evgeni92 » Fri Sep 18, 2015 8:04 am

I use the MPLAB IPE tool and when I try to connect with PICkit3 the message is "Connection Failed."
evgeni92
 
Posts: 6
Joined: Thu Sep 17, 2015 12:03 pm

Re: Problem with PIC12F1572 and PICkit3

Postby ric » Fri Sep 18, 2015 10:55 am

So is this what you did?
Run MPLAB IDE
Set "Family" to "Mid-Range 8-bit MCUs (PIC10/12/16/MCP)
Set "Device" to "PIC12F1572"
Click on "Apply"
Set "Tool" to "PICkit3 S.No :BUR111096290
Click on "Connect"

When I tried that on mine, these are the messages I saw:
Code: Select all
2015-09-18T19:42:13+1000- Completed loading IPE.


*****************************************************

Connecting to MPLAB PICkit 3...

Currently loaded firmware on PICkit 3
Firmware Suite Version.....01.38.10 *
Firmware type..............Enhanced Midrange

Now Downloading new Firmware for target device: PIC12F1572
Downloading bootloader
Bootloader download complete
Programming download...
Downloading RS...
RS download complete
Programming download...
Downloading AP...
AP download complete
Programming download...

Currently loaded firmware on PICkit 3
Firmware Suite Version.....01.39.15
Firmware type..............Enhanced Midrange

Target device was not found (could not detect target voltage VDD). You must connect to a target device to use PICkit 3.

The last message is expected, as my PK3 isn;t connected to any PIC.

What did you see?
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 398
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products

Re: Problem with PIC12F1572 and PICkit3

Postby evgeni92 » Fri Sep 18, 2015 11:01 am

Code: Select all
2015-09-18T12:56:10+0300- Completed loading IPE.


*****************************************************
Connection Failed.


Thanks for the help. I have last question.
The computer have and MPLAB IDE 8.92. Could there be a conflict between two versions. After few hours I try with another pickit3.
Again thanks for the help.
evgeni92
 
Posts: 6
Joined: Thu Sep 17, 2015 12:03 pm

Re: Problem with PIC12F1572 and PICkit3

Postby ric » Fri Sep 18, 2015 11:22 am

evgeni92 wrote:
The computer have and MPLAB IDE 8.92. Could there be a conflict between two versions.

Shouldn't be.
I have MPLAB 8.92, and MPLABX 3.00, 3.05, 3.06 and 3.10 all installed on this PC.
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 398
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products

Next

Return to 14-Bit Core

Who is online

Users browsing this forum: No registered users and 1 guest