Link error

Link error

Postby PICuser » Sun Jul 07, 2019 11:07 pm

I'm using MPLAB X IDE v3.15 with a 16F73.
I have encountered a link error I can't figure out.

Error - could not find definition of symbol 'init_uart' in file './build/default/production/Demod.o'.

I have studied the user guide for the linker but was unsuccessful. What is confusing is that the symbol is not used in the source file. In desperation I renamed the symbol so now the original is nowhere in any source file. But it still causes that link error. If anyone can explain what is happening here I sure would appreciate it. Thank you in advance.
PICuser
 
Posts: 2
Joined: Fri Jul 05, 2019 7:04 pm
PIC experience: Experienced Hobbyist

Re: Link error

Postby ric » Mon Jul 08, 2019 2:44 am

You don't mention, are you working in assembler, or in C?
Coding directly, or using something like MCC (although I doubt that supports old chips like the 16F73)

Can you zip up your whole project and post it here?
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 501
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products

Re: Link error

Postby AussieSusan » Mon Jul 08, 2019 3:34 am

Wild guess - it is being referenced from an include file?
If you have updated the source files, are you sure that they have all been recompiled?
Susan
AussieSusan
Verified identity
 
Posts: 110
Joined: Mon Jun 16, 2014 4:45 am
PIC experience: Experienced Hobbyist

Re: Link error

Postby PICuser » Mon Jul 08, 2019 10:30 pm

Thanks for the response. It was in the include file.
PICuser
 
Posts: 2
Joined: Fri Jul 05, 2019 7:04 pm
PIC experience: Experienced Hobbyist

Re: Link error

Postby ric » Tue Jul 09, 2019 12:17 am

So is your problem solved?
Latest test project, an LED matrix display made from one reel of addressable LEDs. here
User avatar
ric
Verified identity
 
Posts: 501
Joined: Sat May 24, 2014 2:35 pm
Location: Melbourne, Australia
PIC experience: Professional 5+ years with MCHP products


Return to MPLAB X IDE

Who is online

Users browsing this forum: No registered users and 1 guest